02.11.2016 10:56:38
При переносе ModX на другой хостинг возникла ошибка: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead

pic1

Обновить движок возможности не было, т.ч. пришлось искать другой вариант.

Первой идеей было даунгрейдить php до 5.2, но нашелся способ проще!

В файе manager/includes/document.parser.class.inc.php нужно найти функцию:

 
function executeParser() {
        //error_reporting(0);
        if (version_compare(phpversion(), "5.0.0", ">="))
            set_error_handler(array (
                & $this,
                "phpError"
            ), E_ALL);
        else
            set_error_handler(array (
                & $this,
                "phpError"
            ));

- и в ней изменить E_ALL на E_ERROR

Это позволит запустить МодХ проигнорировав часть ошибок


Тэги: MODx

Связанные материалы:

После переноса сайта modx стал выдавать белую страницу со словом Error

Яндекс.Метрика