Явное указание версии php phpstorm

08.03.2019 06:55:52

Для изменения версии php для проекта в IDE Phpstorm, нужно зайти в File - Settings - Languages & Frameworks - PHP

Но если в проекте используется composer, то данные из него переопределят эту настройку.

Поэтому можно задать версию php через composer.json так:

 
{
    "require": {
        "php": "^7.0",
        "oddler/test": "^1.5"
    }
}


Категории: PHP, Настройка Конфиги
Пометки: phpstorm composer php version
Яндекс.Метрика